2

Basic Excel Accessibility for Students
By: Lindsay Bryde
Table of Contents
Welcome	2
Learning Objectives	2
Note on links	3
Accessibility Assistant	3
Why Should You Run the Accessibility Assistant First?	3
Where is the Accessibility Assistant in MS Excel?	3
Interpreting Accessibility Assistant Results	4
Accessibility Assistant Limitations: Still Needs That Human Touch!	6
Knowledge Check 1: Accessibility Assistant?	8
Congratulations	8
Tables, Labels, and Layout	8
Tables and Labels Simplify Complex Relationships	8
How to Create Accessible Table Headers	9
Additional Resources	10
Naming Tables and Sheets	10
Cell A1	11
Inaccessible Formatting Methods	12
Knowledge Check 2: Tables, Labels, and Layout	13
Congratulations	14
Images and Non-text Content	14
Make Images and Non-textual Content Accessible	14
How to Apply Alt Text	15
Mark as Decorative	16
Knowledge Check 3: Images and Non-text Content	17
Congratulations	17
Charts	18
Why Accessible Charts Help Everyone	18
Select the Best Chart and Layout to Organize Data	18
Add Descriptive Elements and Use Distinct Visuals	19
Additional Resources	20
Knowledge Check 4: Charts	20
Congratulations	20
Conclusion	20
Knowledge Check Answer Key	20
Knowledge Check 1 Answers: Accessibility Assistant	20
Knowledge Check 2 Answers: Tables, Labels, and Layout	20
Knowledge Check 3 Answers: Images and Non-text Content	20
Knowledge Check 4 Answers: Charts	20

[image: Stony Brook University's logo]
Figure 1 Stony Brook University Logo
[bookmark: _Toc197596367]Welcome
In this course, we provide guidance and introductory instructions on creating accessible Microsoft Excel (MS Excel) spreadsheets. There are many elements that go into making content accessible; this guide is not exhaustive.
It is recommended that you review our training "Picking the Most Accessible Format for Your Content: PDF, Word, or PowerPoint(opens in a new tab) " to ensure that a Word document is the best format for your content.
The estimated time to complete this course is 15-20 minutes. 
[bookmark: _Toc197596368]Learning Objectives
By the end of this guide, you will be able to:
· Locate and run a report using the Accessibility Assistant tool.
· Explain the limitations of Accessibility Assistant and what needs to be checked manually for accessibility.
· Create tables with row headers.
· Describe inaccessible formatting practices and how to mitigate them.
· Generate descriptive alt text for images.
· Apply accessible layouts and labels to charts.
For more information about document accessibility, please reach out to CELT by emailing celt@stonybrook.edu (opens in a new tab)(opens in a new tab).
If you come across an accessibility barrier in this guide, please let us know by emailing celt@stonybrook.edu (opens in a new tab)(opens in a new tab).
[bookmark: _Toc197596369]Note on links
All links in this course open to a new tab.
[bookmark: _Toc197596370]Accessibility Assistant
[bookmark: _Toc197596371]Why Should You Run the Accessibility Assistant First?
Microsoft Excel features an Accessibility Assistant that can help you find accessibility issues within your spreadsheets. This can be a good way of getting a high-level overview of potential accessibility concerns.
It is important to recognize that automated accessibility checkers are only capable of detecting some of the issues that can affect the accessibility of your document. It is critical that you always review your document, even if the Accessibility Assistant does not find anything wrong.
At the end of this module, you should be able to:
· Locate Microsoft Excel's Accessibility Assistant and run an accessibility report. 
· Interpret Accessibility Assistant Inspection results. 
· Locate additional support under the Accessibility Assistant results.
· Identify Accessibility Assistant's limitations.
[bookmark: _Toc197596372]Where is the Accessibility Assistant in MS Excel?
The Accessibility Assistant runs in the background of your document, checking the accessibility of content in real-time, while you are working.
To see what information is being captured:
1. Click the Review tab of the ribbon.
2. Select Check Accessibility to review the status of your document, the Accessibility Assistant pane will open on the right.
3. In the Accessibility Assistant pane, review and address the results from your check.
[image: The Review tab is open and the Check Accessibility icon is noted with an arrow pointing toward it.]
Figure 2 The Review tab is open and the Check Accessibility icon is noted with an arrow pointing toward it.
[bookmark: _Toc197596373]Interpreting Accessibility Assistant Results
Overview of Accessibility Assistant Findings
Source: Using the Improve accessibility in your documents with the Accessibility Assistant(opens in a new tab).
The Accessibility Assistant helps you find and resolve issues with your document. It's divided into the following categories:
· Color and Contrast: ensures all text is easy to read.
· Media and Illustrations: ensures all images and multimedia have alt text and proper alignment on the page.
· Tables: checks the table's structure and format.
· Document Structure: ensures headings and labels are being used.
· Document Access: verifies if the document can be accessed programmatically (e.g., used by screen readers).
Checking for Issues
Any items that are checked that need additional review have a white text and a number next to it (the number indicates how many issues there are). Click the name of the issue to drill-down and see a description of the concern, and options to resolve it.
Any items that are greyed out and have a checkmark next to them are issues that the assistant checked for and did not identify in your document. These items cannot be clicked into within the document.
[image: The Accessibility Assistant pane is open and displays a variety of issues with numbers displaying how many there are and some are greyed out/resolved.]
Figure 3 The Accessibility Assistant pane is open and displays a variety of issues with numbers displaying how many there are and some are greyed out/resolved.
Learning Tips
If you'd like to look up more information about any of the items listed in the Accessibility Assistant, click on the item in question. At the bottom of the Accessibility Assistant pane will be a Learning Tips link that you can click and be taken to additional guidance from Microsoft.
[image: The Accessibility Assistant is drilled down to a specific item. The Learning Tip link at the bottom of the pane is highlighted with a box and an arrow pointing to it.]
Figure 4 The Accessibility Assistant is drilled down to a specific item. The Learning Tip link at the bottom of the pane is highlighted with a box and an arrow pointing to it.
[bookmark: _Toc197596374]Accessibility Assistant Limitations: Still Needs That Human Touch!
The Accessibility Assistant is a good starting point, but it is important to recognize that there are limits to what any automated tool can detect.
You will need to check your document to ensure the proper access strategies are applied to your content. You cannot rely on the Accessibility Assistant as the sole means of addressing accessibility in your presentation.
The following are Accessibility Assistant limitations to consider.    
Alt Text
Although the Accessibility Assistant can comb through a spreadsheet and generate a thorough list of all accessibility errors, it cannot identify meaningful alternate text based on the sheet's context. That is where you come in.
For example, if the alternate text of a picture is "image1.jpg," the Accessibility Assistant will mark that picture accessible even though it is not descriptive enough.
It is still effective practice to individually check images for appropriate alternate text based on the context of the document's content.  
[image: The Alt Text pane in Microsoft Word. An auto-generated caption is in the textbox. There are buttons below it to Mark the image as decorative or to approve the autogenerated caption.]
Figure 5 The Alt Text pane in Microsoft Word. An auto-generated caption is in the textbox. There are buttons below it to Mark the image as decorative or to approve the autogenerated caption.
Color Conveying Meaning
Accessibility Assistant cannot determine if color alone is being used to convey meaning (e.g., color coding a chart without providing a key).
This is something you need to check and address manually.
Complex Structures
Accessibility Assistant struggles with interpreting and connecting information in complex tables with split and/or merged cells. It cannot discern the relationship between the fields. This is why it's a best practice to use simple tables that focus on one topic/subject at a time.
Color Contrast
The Accessibility Assistant has a criteria for "Hard to read text contrast." This applies to plain text on the background.
Accessibility Assistant does not catch all contrast issues when you use SmartArt or charts at this time. Those need to be manually checked by content creators. The WebAim Color Contrast Checker is a good tool for this work.   
Do no assume that the pre-designed themes will provide sufficient color contrast. It is important to verify and ensure that your font colors are providing sufficient contrast for the background colors.
[bookmark: _Toc197596375]Knowledge Check 1: Accessibility Assistant?
Answer the following question to self-check your knowledge (answers are at the end of the document).  
1. What are things you need to manually check in your document that the Accessibility Assistant won't be guaranteed to catch?
a. Quality of alt text
b. When color alone conveys meaning
c. Reading order for complex tables
d. All of the Above
[bookmark: _Toc197596376]Congratulations
You completed the Accessibility Assistant Module. The Accessibility Assistant is a great start in reviewing MS Excel accessibility. It has its limitations - don't forget to double check your work.
Can You...
· Locate Microsoft Excel's Accessibility Assistant?  
· Interpret Accessibility Assistant results?
· Locate additional support under the Accessibility Assistant results?
· Identify Accessibility Assistant's limitations?
Before you continue to the next module, make sure you answer the questions above! If you need additional support on any of the bullet points above, please review this module. 
[bookmark: _Toc197596377]Tables, Labels, and Layout
[bookmark: _Toc197596378]Tables and Labels Simplify Complex Relationships
Tables can provide a means of presenting complex information in a manner that makes it easy to comprehend and identify relationships between the data.
This is why it's important to have a clear purpose for each sheet, consistent and descriptive labels, and simple formatting to best organize information.
[image: ]
At the end of this module, you should be able to:
· Explain why it's important to identify a header row and include unique labels for each sheet, column, and field. 
· Create a header row and rename the all tables and sheets.
· Describe inaccessible table formatting methods to avoid.
[bookmark: _Toc197596379]How to Create Accessible Table Headers
All tables need an identified header. To set the top row of your table as the header accessibly:
1. Select the cells you want to include in the table.
2. On the Insert tab in the ribbon, select Table.
3. Select the My table has headers check box and select OK.
4. Type new, descriptive names for each column in the table.
[image: The Create Table box is open. The My table has headers box is checked to demonstrate best practice.]
Figure 6 The Create Table box is open. The My table has headers box is checked to demonstrate best practice.
[bookmark: _Toc197596380]Additional Resources
Video: Create an accessible table
This Microsoft video reviews how to create an accessible table with a header row.
[bookmark: _Toc197596381]Naming Tables and Sheets
Naming tables and sheets in Excel is important for maintaining clarity and organization, especially in complex workbooks. When you assign meaningful names, it becomes easier to navigate and understand the data structure, reducing the risk of errors.
Named tables and sheets enhance the readability of formulas and references, making it simpler to audit and update your work. Well-named elements improve collaboration, as users can quickly grasp the purpose and content of each table or sheet, leading to more efficient teamwork and data management.
Naming a Table
1. Select the table that needs to be named.
2. Go to Design>Table Name.
3. Enter a unique name for the table in the textbox.
1. Note: your name must be one word with no breaks, you can use underscores if you want to connect more than one word.
4. Hit the enter button to finalize your entry and exit the textbox.
5. Repeat for all tables on the sheet (e.g. if you have a main table of data and a separate table for a key).
[image: The Design tab is open and an arrow is point to the Table Name textbox.]
Figure 7 The Design tab is open and an arrow is point to the Table Name textbox.
Naming a Sheet
1. Right-click on the sheet that needs to get renamed.  
2. Select the Rename option from the drop-down menu, the current sheet's name will become a textbox.
3. Enter the sheet's new and unique name in the textbox.
4. Hit the enter button to finalize the new name and close the textbox.
[image: The Sheet drop-down is open and the Rename option is noted with an arrow.]
Figure 8 The Sheet drop-down is open and the Rename option is noted with an arrow.
[bookmark: _Toc197596382]Cell A1
Source: Accessibility best practice with Excel speadsheets(opens in a new tab)
Screen readers start reading any worksheet from cell A1. This cell must have data in it, otherwise a screen reader will initially be silent and users may think something bigger is wrong.
A1 can be as simple as noting the title of the table, chart, or first column's header information.
Microsoft recommends adding instructions or an overview of the sheet in cell A1 if the sheet is long or complex. This instructional text can match the background color. This will hide it from people who can see, but allows it to be read by screen readers.
[bookmark: _Toc197596383]Inaccessible Formatting Methods
There are some common formatting mistakes that you want to avoid:
Merging, nesting, and splitting cells
When tables contain merged cells and nested tables, each cell must be uniquely identified and associated with the appropriate header cell. MS Excel does not provide a means of doing this, so it is recommended that you keep your tables simple - for the sake of clear communication as well as for accessibility.
Create your table using the Draw tools
While this tool can be valuable for creating images and certain annotations within documents, assistive technology won't be able to interpret the content of your drawn table to a user.
Control spacing in your table with blank rows or columns
When blank spaces are added in a table, some screen readers will "read" each empty cell to the user. That can take up a lot of their time and be disorienting for someone listening in. It is better to adjust the line spacing or use borders to create visual spaces between columns or rows.
Use tables for design layout
If there's no clear purpose or logical connection between each field in the table, it makes the information difficult to understand. This is when it's better to use Microsoft Word to convey information and content using its accessible tools and features.
Leaving extra empty sheets
If you initially created three sheets and only used two sheets, you want to delete the extra sheet. Leaving empty sheets with no data, labels, or headers can create confusion for users relying on a screen reader since there's no information to tell them that they can skip that sheet.
To remove a sheet:
1. Right-click on the sheet that needs to go.  
2. Select the Delete option from the drop-down menu.
[image: The Sheet drop-down is open and the Delete option is noted with an arrow.]
Figure 9 The Sheet drop-down is open and the Delete option is noted with an arrow.
Leaving blanks cells
You want to avoid leaving blank cells, columns, and rows as much as possible. A blank cell might lead a screen reader user to think they've reached the end of the table.
If you cannot avoid a blank cell, column, or row, you need to explain it's blank. For example, you can type "N/A" or "Intentionally Blank" in the cell.
Freezing or hiding rows or columns
Frozen rows and columns should be avoided whenever possible. It is also inadvisable to hide rows or columns because of the difficulty users that require screen readers or keyboard navigation face. For example, if someone uses a keyboard shortcut to go to "Home" after freezing the top row, they'll be taken to cell A2 instead of cell A1.
[bookmark: _Toc197596384]Knowledge Check 2: Tables, Labels, and Layout
Answer the following question to self-check your knowledge (answers are at the end of the document).  
1. Can merged and split cells in a table be made accessible?
a. Yes, you need to indicate this in the header cell(s).
b. Yes, they wouldn't let you have these features if they weren't accessible.
c. Yes, you need to indicate where the merged or split cells are in the alt text.
d. No, to have an accessible table, there can't be merged or split cells.
[bookmark: _Toc197596385]Congratulations
You just completed the Tables, Labels, and Layout Module! Here are some brief summary points:
· Keep your tables simple: no nested tables or merged cells.
· Format your sheet as a table to add a header row.
· Name each table and sheet.
Can You...
· Explain why it's important to identify a header row and include unique labels for each sheet, column, and field?
· Describe inaccessible formatting practices and how to avoid them?
· Create a header row and rename the all tables and sheets?
Before you continue to the next module, make sure you answer the questions above! If you need additional support on any of the bullet points above revisit this module. 
[bookmark: _Toc197596386]Images and Non-text Content
[bookmark: _Toc197596387]Make Images and Non-textual Content Accessible
Images present a powerful and effective means of communicating information.
However, our computers aren't able to determine what is in a picture for us, so to make our documents accessible we have to provide the image description when we create the document.
The specific process to describe an image will vary depending on the software you are using to create your document. However, the textual description for an image is referred to as an "Alt Text" description.    
[image: ]
At the end of this module, you should be able to:
· Explain the importance of alt text.
· Apply alt text to an image in Microsoft Excel.
· Recognize when to mark an image as decorative.
[bookmark: _Toc197596388]How to Apply Alt Text
Alt text can be added to a variety of objects, including: images, clip art, charts, tables, SmartArt, audio files, and videos.
To get started, you need to open the Alt Text pane in one of two ways:
1. Right-click the object and select View Alt Text from the drop-down.
2. Click the object and go to Format > Alt Text.
1. The Alt Text pane will open on the right-hand side of the screen.
Next, type your description of the object including an physical characteristics of it and its purpose in the textbox.
[image: The image drop-down menu is displayed with the View Alt Text option noted with an arrow.]
Figure 10 The image drop-down menu is displayed with the View Alt Text option noted with an arrow.
[bookmark: _Toc197596389]Mark as Decorative
If an image adds no informational value, it's visually appealing but not adding anything to the content otherwise, you want to mark it as decorative. When you mark an image as decorative, it will be ignored by screen readers as if the image isn't there.
Images should only be marked as decorative if they absolutely do not add to the content; it should not be used for every image to avoid alt text or expedite a process.
How to Mark a Decorative Image
1. Open the Alt Text pane.
2. Check the Mark as decorative checkbox.
[image: The Alt Text pane is open and the Mark as decorative checkbox is checked.]
Figure 11 The Alt Text pane is open and the Mark as decorative checkbox is checked.
[bookmark: _Toc197596390]Knowledge Check 3: Images and Non-text Content
Answer the following question to self-check your knowledge (answers are at the end of the document).  
1. When is it best to mark an image as decorative in a document or presentation?
a. When the image contains important information that needs to be conveyed to all users.
b. When the image is used purely for visual appeal and does not add any meaningful content.
c. When the image includes text that needs to be read by screen readers.
d. When the image is a chart or graph that represents data.
[bookmark: _Toc197596391]Congratulations
You completed the Images and Non-textual Content Module!
Can You...
· Explain the importance of alt text?
· Apply alt text to an image in MS Excel?
· Recognize when to mark an image as decorative?
Before you continue to the next module, make sure you answer the questions above! If you need additional support on any of the bullet points above revisit this module. 
[bookmark: _Toc197596392]Charts
[bookmark: _Toc197596393]Why Accessible Charts Help Everyone
Making charts accessible is essential to ensure that all users, including those with disabilities, can understand and interact with the data presented.
Accessible charts enhance overall usability, making it easier for all users to interpret and utilize the data effectively, thereby improving communication and decision-making processes.
[image: ]
At the end of this module, you should be able to:
· Explain why you want to use a chart with direct labels.
· Provide descriptive elements and distinct visuals.
[bookmark: _Toc197596394]Select the Best Chart and Layout to Organize Data
Once you've chosen the data you want to visualize, you need to insert a chart by going to the Insert tab and selecting a chart type.
To make it more accessible, go to Design>Quick Layout and select a chart design that includes direct labels (labels that appear within the chart).
[image: The Table Design ribbon is open and the Charts section is noted in the middle of the ribbon with an arrow.]
Figure 12 The Table Design ribbon is open and the Charts section is noted in the middle of the ribbon with an arrow.
[bookmark: _Toc197596395]Add Descriptive Elements and Use Distinct Visuals
Accessible charts need to provide clear and descriptive titles, direct labels, distinct visuals, and alternative text, which help screen readers convey the information to visually impaired users.
Add Descriptive Titles and Labels
Replace generic titles with meaningful ones. For example, a generic placeholder like "Chart Title" should be replaced with something specific like "Quarterly Sales Data."
Add axis titles by selecting the chart, then going to Design > Add Chart Element > Axis Titles and typing descriptive titles for both axes.
Add Data Labels
Include data labels to show exact values. This can be done by selecting the chart, then going to Design > Add Chart Element > Data Labels and choosing a position for the labels
Include Alt Text
Add alternative text to describe the chart.
Right-click the chart, select View Alt Text, and provide a concise description of the chart’s content and purpose
Create sufficient contrast between lines, bars, and shapes
While some chart designs present each line, bar, or shape with its own unique color, you need to check that they have sufficient color contrast (otherwise all the lines, bars, and shapes could look the same).
To change a color, right-click the object and select a new color from drop-down menu of formatting options that will appear.
[image: The formatting drop-down for a selected chart is open.]
Figure 13 The formatting drop-down for a selected chart is open.
[bookmark: _Toc197596396]Additional Resources
Video: Create more accessible charts in Excel
This Microsoft video reviews how to create an accessible chart.
[bookmark: _Toc197596397]Knowledge Check 4: Charts
Answer the following question to self-check your knowledge (answers are at the end of the document).  
1. Which of the following steps is NOT necessary for making a chart accessible in Microsoft Excel?
a. Adding descriptive titles and labels to the chart.
b. Using high-contrast colors.
c. Including alternative text to describe the chart.
d. Adding a background image to make the chart visually appealing.
[bookmark: _Toc197596398]Congratulations
You just completed the Charts Module!
Can You:
· Explain why you want to use a chart with direct labels?
· Provide descriptive elements and distinct visuals?
Before you continue to the next module, make sure you answer the questions above! If you need additional support on any of the bullet points above revisit this module. 
[bookmark: _Toc197596399]Conclusion
You have completed the Basic Microsoft Excel Accessibility for Students course!
Please fill out the following feedback form to record your completion of this course and to provide feedback for improvements. 
[bookmark: _Toc197596400]Knowledge Check Answer Key
[bookmark: _Toc197596401]Knowledge Check 1 Answers: Accessibility Assistant
1. D
[bookmark: _Toc197596402]Knowledge Check 2 Answers: Tables, Labels, and Layout
1. D
[bookmark: _Toc197596403]Knowledge Check 3 Answers: Images and Non-text Content
1. B
[bookmark: _Toc197596404]Knowledge Check 4 Answers: Charts
1. D
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