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[bookmark: _Toc197595790]Introducing the Reading Order tool
The Reading Order tool is a useful tool that can identify the content type or tag type of each object on a page. Recall that objects include text, images, and tables.
The Reading Order tool can also help with tagging page objects so that they appear in the Tags Panel. For example, if specific text content is intended to be classified as a Heading 1, the Reading Order tool can confirm this or change the content type or tag type to "H1" for this specific content.
[bookmark: _Toc197595791]Distinguishing the Reading Order Tool & The Accessibility Tags Panel
The Reading Order tool is primarily a content object type identifier, and should not be relied on in its editing capabilities to create an accurate reading order.
The Reading Order tool reveals the semantic structure, and to some degree, content sequencing. Although one can use the Reading Order tool to manipulate the reading sequence, it is highly recommended to use the Accessibility tags panel to edit and correct logical reading order in a PDF document.
While the Reading Order tool identifies various types of content, the Accessibility tags panel provides a reliable technical workaround for what is considered the logical reading order for an accessible PDF document per the PDF/UA-1 standard.
[image: The Reading Order tool is open and the PDF is displaying the page content order in numerical order.]
Figure 1 The Reading Order tool is open and the PDF is displaying the page content order in numerical order.
[bookmark: _Toc197595792]Reading Order Tool & Order Panel
[bookmark: _Toc197595793]Reading Order tool
The Reading Order tool is located in the Prepare for accessibility tool.
To access the Reading Order tool:
1. Choose All Tools > Prepare for accessibility.
Select the Fix reading order in the left pane.
[bookmark: _Toc197595794]Order Panel
Although the Order panel can shift objects around, it is highly recommended to verify and edit logical reading order in the Accessibility tags panel. 
To access the Order panel:
· Select the Reading Order tool in the right pane.
· In the Reading Order dialog box, click Show Order Panel.
· In the Order panel, navigate to view a list of highlighted regions that appear in the document pane.
· Drag the tag for a highlighted region to the location you want.
· As you drag, a line appears to show potential locations. After you drag an item to a new location, the highlighted regions are renumbered to show the new reading order. You can select and move multiple, adjacent regions.
[bookmark: _Toc197595795]Where Is Everything Located?
[image: The Prepare for Accessibility tool (on left), Reading Order tool (dialog box in the middle), and the Order panel (on right) are all open with boxes surrounding each with a label stating their name.]
Figure 2 The Prepare for Accessibility tool (on left), Reading Order tool (dialog box in the middle), and the Order panel (on right) are all open with boxes surrounding each with a label stating their name.
[bookmark: _Toc197595796]Two Ways to Use the Reading Order tool
There are two ways you can use Reading Order tool:
1. Verify Content Type/Tag Type 
2. Manually add tags to an untagged document
[bookmark: _Toc197595797]Verify & reclassify content type/tag type 
When Reading Order is engaged, use "Structure Types" to review semantic structure. 
There will be tiny labels that appear to each of the highlighted objects.
[image: The Reading order tool is open and set to "Structure Types." There is an arrow pointing from this setting to where the labels appear on the PDF.]
Figure 3 The Reading order tool is open and set to "Structure Types." There is an arrow pointing from this setting to where the labels appear on the PDF.
[bookmark: _Toc197595798]Create Manual Tags
The Reading Order tool can create tags in untagged PDFs or add new tags to an existing structure. Simply draw a zone around the object and select the appropriate structure type.
However, this manual tagging doesn’t provide the same level of detail to the tagging structure as the Add Tags To Document command. For example, the Reading Order tool is not able to mark content as a bulleted and numbered list whereas the Add Tags to Document function is capable of recognizing such content.
In order to properly classify objects such as bulleted or numbered lists, zone and mark the object (covered on the following page) with any of the Reading Order Options (for example "P" is for "paragraph" or normal body text.)
Once the object is tagged, enter the Accessibility tags panel to properly reclassify its type. 
Before you clear the existing structure, make sure that manual tagging is your only recourse. If possible, create the final accessible version of the document in the source document like Microsoft Word, and then export to PDF. This will alleviate the need to manually tag the document.
[bookmark: _Toc197595799]Use Reading Order to Examine & Repair Your PDF
When we show up to the present moment with all of our senses, we invite the world to fill us with joy. The pains of the past are behind us. The future has yet to unfold. But the now is full of beauty simply waiting for our attention.
[bookmark: _Toc197595800]Tips for Using the Reading Order tool
· Save the document (or a copy of it) before you use the Reading Order tool. You can’t use Undo to reverse changes made with this tool, so reverting to a saved document is the only way to undo such a change.
· Choose View > Page Display > Single Page View, when using the Reading Order tool. When you click the Clear Page Structure button, Acrobat clears tags from all visible pages, even pages that are only partially visible.
The Reading Order requires a "tagged" PDF. Always make sure you are working with a tagged PDF document or else run the Prepare for accessibility tool on the PDF before working with the Reading Order.
[bookmark: _Toc197595801]Structure Labels
While this can be done automatically, please verify that the tag type in the Accessibility tags panel is correct for each object.
The content within your PDF document will be organized in content blocks that contain a label in the upper left-hand corner of each content block.
Make sure the text that should be styled as a Heading 1 is displaying the H1 label.
Heading levels 1 through 6 are represented by the H with the corresponding number to indicate the level (H1, H2, H3, etc...).
Text that is not styled as a heading style will be labeled with the p (for paragraph) label:.
Images will be labeled with the "Figure" label.
[image: Examples of a header, paragraph, and figure structure label.]
Figure 4 Examples of a header, paragraph, and figure structure label.
[bookmark: _Toc197595802]Page Content Order
When the "Page content order" radio-button is selected from the Reading Order tool, each content block will display a numerical value. This is NOT the definitive source for the logical reading order of the page, but rather is the "painting order" of the visual rendering of the content on the page.
Do not rely on the Page Content Order and the Order Panel to evaluate and manage the logical reading order of the document. While the logical reading order may be the same in both the Order panel and Accessibility tags panel, this is not always true.
[image: The page content order is displayed on a PDF with numbers displaying next to each new line/entry.]
Figure 5 The page content order is displayed on a PDF with numbers displaying next to each new line/entry.
Ultimately, screen-readers will follow the structure in the Accessibility tags panel; not the Order panel. Save time and effort by deferring to the Accessibility tags panel to manage logical reading order.
[bookmark: _Toc197595803]Zoning and Marking Text
After running Automatically tag PDF to Document function, it may be necessary to manually modify the document content. For example, a two-column document may be recognized incorrectly as one single content zone when in fact it is actually two separate content zones.
Additionally, information that may be relevant to the page content may not have been recognized during the tagging process, resulting in relevant content that is not part of the document’s logical reading order. It is also possible that content was added to the document reading order, when in fact it does not belong.
[bookmark: _Toc197595804]Zone & mark text tutorial
Adobe Acrobat’s Reading Order tool allows authors to manually zone page content and either add or remove this information to the document’s reading order. The Reading Order tool also allows authors to classify content as various heading levels (i.e., Heading 1, Heading 2, Heading 3) as well as Figures, Tables, or other structural markup. 
Step 1: Enable the Reading Order tool
To zone and mark text, enable the Reading Order tool  (All Tools > Prepare for Accessibility > Fix reading order). It is recommended to add tags to the document before using the Reading Order tool.
Step 2: Select the content you want to zone
The mouse pointer will turn into a set of cross-hairs.
Click and drag a box around the content you wish to zone.
Draw the zoning region larger than the actual region of the content (in some cases, you may have to overlap into other content regions to zone correct content).
Step 3: Check that content is zoned
[image: An image is being zoned on a PDF. It has a dark pink box around it.]
Figure 6 An image is being zoned on a PDF. It has a dark pink box around it.
The content you have “zoned” will have a dark pink outline around the image, characters, or words.
Step 4: Select the content type
[image: An image of a dog has been zoned, and the Figure button is being hovered over, ready to select and tag it.]
Figure 7 An image of a dog has been zoned, and the Figure button is being hovered over, ready to select and tag it.
Choose the appropriate content type in the Reading Order tool.
Step 5: Save the document
[image: The image of the dog is now tagged as a figure. It has a black and white text box at the top of the image noting that it's a figure, and the overall image is within a light grey box.]
Figure 8 The image of the dog is now tagged as a figure. It has a black and white text box at the top of the image noting that it's a figure, and the overall image is within a light grey box.
Save the document in order to retain the changes. Content that have been zoned and marked will appear as in a gray box with a number in the upper left corner.
[bookmark: _Toc197595805]De-Cluttering PDF Documents
PDF documents are supposed to preserve a consistent look and feel across different devices and operating systems, but PDF documents often have a hidden side that is not always visibly apparent.
[bookmark: _Toc197595806]Empty Tags
These empty regions may be formatting elements that may have been used for visual formatting purposes (e.g., extra carriage returns). In the example to the right, are extra carriage returns in the document that were - correctly - converted into tags. These are elements that are left-over from the document authoring process and, as they serve no actual purpose, may be set as Background (and thus removed from the document's structure).
[image: A PDF with three empty tags due to carriage returns in the lower-left corner. All three have a box  and an arrowing noting them.]
Figure 9 A PDF with three empty tags due to carriage returns in the lower-left corner. All three have a box  and an arrowing noting them.
[bookmark: _Toc197595807]Remove empty tags
1. With a PDF document open and the Reading Order activated: Within the Reading Order, ensure that the "Display like elements in a single block" option is NOT selected. 
2. Locate any empty tags, and select them by clicking on the white label in the upper left-hand corner.
3. With the empty tag element selected, click the Background/Artifact button on the Reading Order.
4. Repeat steps 4 and 5 on each page of the PDF until all of the empty tags have been removed.
[image: The Reading order tool is open with the setting below the Table Editor noted by a black box.]
Figure 10 The Reading order tool is open with the setting below the Table Editor noted by a black box.
[bookmark: _Toc196906701][bookmark: _Hlk188603265][bookmark: _Toc197595808]Learn More About Document Accessibility
For more information about document accessibility, please reach out to CELT by emailing celt@stonybrook.edu (opens in a new tab).
To view additional tutorials and resources, visit CELT's Student Accessibility page (opens in a new tab).
Please fill out the Feedback Survey Form (opens in a new tab) to record your completion of this course and to provide feedback for improvements. 
[image: Stony Brook University's logo]
Figure 11 Stony Brook University's logo
[bookmark: _Toc197595809]Note on Course Attribution
This course has been adopted from San Diego Mesa College's PDF Accessibility (Self-Paced) course(opens in a new tab), licensed under a Creative Commons Attribution 4.0 International License(opens in a new tab). San Diego Mesa College adopted their training from PDF Accessibility by CCC Accessibility Center(opens in a new tab), licensed under a Creative Commons Attribution 4.0 International License(opens in a new tab). Development of this course was funded by a grant from the California Community Colleges' Chancellor's Office. *Our version is condensed to focus on the Module "Tag Panel" and contains additions to reflect Adobe Acrobat's current navigation and features.
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