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[bookmark: _Toc229404328]Welcome
In this course, we provide guidance and introductory instructions on creating accessible content in Google’s tools (Docs, Slides, and Sheets) using Grackle Workspace (includes Grackle Docs, Slides, and Sheets). There are many elements that go into making content accessible; this guide is not exhaustive.
It is highly recommended that you review the Digital Accessibility Resource Guide before beginning this course.
Important: Licenses to Grackle Workspace are active for all Stony Brook email accounts.
The estimated time to complete this course is 20-30 minutes.
[bookmark: _Toc229404329]Learning Objectives:
By the end of this guide, you will be able to
· Demonstrate how to install, launch, and use Grackle Workspace within Google Docs, Slides, and Sheets to scan documents for accessibility issues.
· Recognize common accessibility barriers (e.g., missing alt text, poor heading structure, low contrast) and use Grackle Workspace to correct them.
· Generate accessibility reports using Grackle Workspace, and interpret the results to improve document accessibility.
· Export accessible copies of content from Google Docs, Slides, and Sheets for dissemination using Grackle Workspace.
For more information about document accessibility, please reach out to CELT by emailing celt@stonybrook.edu(opens in a new tab) (opens in a new tab).
If you come across an accessibility barrier in this guide, please let us know by emailing celt@stonybrook.edu(opens in a new tab) (opens in a new tab).
[bookmark: _Toc229404330]Note on alternative text:
This course provides alternative text through image descriptions either next to or below an image, and through the alt text tag for images in interactive content blocks.
[bookmark: _Toc229404331]Note on images:
Select images to view them in a larger frame.
[bookmark: _Toc229404332]Note on links:
All links in this course open to a new tab
[bookmark: _Toc229404333]Initial One Time Setup
This is a process that must be completed in Google Docs, Slides, and Sheets the first time you launch Grackle Docs, Slides, or Sheets in each tool. The setup ensures that the accessibility checker integrates properly with your Google Workspace, allowing you to scan and improve the accessibility of your documents effectively.
Note: Grackle Docs, Slides, and Sheets can only be run on Google Docs, Slides, and Sheets documents. If a Microsoft file has been uploaded to Google Drive, it cannot be scanned. You’ll need to convert the file to a Google one, or use Microsoft’s Accessibility Assistant built into Microsoft’s tools.
Follow the Step by Step process below on how to set up Grackle Docs. Click on each image for a larger view.
[bookmark: _Toc229404334]Step 1
[image: Screenshot of Step 1, displaying the Extensions drop-down menu options.]
To begin, click Extensions>Grackle Docs>Launch, a dialog box will open.
[bookmark: _Toc229404335]Step 2
[image: Screenshot of Step 2, a disclaimer asking a user for permission to run Grackle Docs.]
Select the Ok button to give Grackle Docs, Slides, or Sheets permission to run.
[bookmark: _Toc229404336]Step 3
[image: Screenshot of Step 3, asking a user to login to their @stonybrook.edu email account.]
Select your @stonybrook.edu(opens in a new tab) email account from a list of account options. If it’s not listed, select Use another account to sign in to it.
[bookmark: _Toc229404337]Step 4
[image: Screenshot of Step 4, displaying a user's name and email address, prompting them to confirm their identity.]
Click the Continue button to confirm your account information.
[bookmark: _Toc229404338]Step 5
[image: Screenshot of Step 5, displaying a select all checkbox and multiple criteria of what Grackle Docs, Sheets, and Slides will scan to produce its accessibility report.]
Click Select all to provide Grackle Docs, Slide, or Sheets access to review your content and guide you through the steps to remediate the content.
[bookmark: _Toc229404339]Step 6
[image: Screenshot of Step 6, providing links to the products Privacy Policy and Terms of Use and a request to confirm that the user accepts them.]
Review the Privacy Policy and Terms of Service to understand the product. Click the Continue button to confirm you are willing to accept their policy and terms.
[bookmark: _Toc229404340]Step 7
[image: Screenshot of Step 7, displaying a Google Slide show with Grackle Slide open in a side panel.]
You will be returned to your document and Grackle Docs, Slides, or Sheets will display in a panel on the right side of the screen with a report on your document.
[bookmark: _Toc229404341]Knowledge Check 1: Initial One Time Setup
Answer the following question to self-check your knowledge (answers are at the end of the document).  
1. Where do you find Grackle Workspace to launch it?
a) Select your @stonybrook.edu email account
b) Click Select all to provide access
c) Click Extensions > Grackle Docs > Launch
d) Review the Privacy Policy and Terms of Service
[bookmark: _Toc229404342]General Navigation
[bookmark: _Toc229404343]Grackle Sidebar Overview
The Grackle sidebar appears on the right side of your document when launched. It provides a comprehensive report of accessibility issues, categorized by severity, such as errors, warnings, and suggestions. This sidebar also offers export options to help you create accessible content efficiently.
Using the sidebar, you can quickly identify and address accessibility barriers in your document. It serves as a central hub for managing and improving document accessibility.
[image: Screenshot of Grackle Docs with the Re-Check button circled.]
Figure 2 The "Re-check" button to refresh Grackle's accessibility reports.
[bookmark: _Toc229404344]Using the Re-Check Button
After making changes to your document, the Re-Check button allows you to update the accessibility report. This ensures that any resolved issues or new barriers are accurately reflected in the report. Note that the report does not auto-update with changes.
A re-check may take a minute or more to complete, depending on the length and complexity of your document. This feature is essential for maintaining an up-to-date view of your document's accessibility status.
[image: Screenshot of Grackle Docs with the Export as PDF button circled]
Figure 3 The "Export to PDF" button creates accessible PDFs from Grackle Docs and Slides.
[bookmark: _Toc229404345]Export to PDF Button
The Export to PDF button is available in Google Docs and Slides. Use this button to generate an accessible PDF copy of your document once all accessibility indicators have been passed with a green checkmark or a green checkmark with a red exclamation mark.
Before using this feature for the first time, you must grant Grackle permission to export content to your Google Drive. This ensures that your PDF meets accessibility standards and is ready for distribution.
[image: Screenshot of Grackle Sheets with the Download HTML button circled.]
Figure 4 The "Download HTML" button to generate accessible code from Grackle Sheets.
[bookmark: _Toc229404346]Download HTML Button
The Download HTML button is available exclusively in Google Sheets. This feature allows you to generate accessible HTML code for your content, which can then be published to a web page, such as a page on Brightspace.
Ensure that all accessibility indicators have been passed with a green checkmark or a green checkmark with a red exclamation mark before using this feature. This guarantees that the exported HTML meets accessibility standards.
[image: Grackle Docs with the Options and Commands menu open.]
Figure 5 The "Options and Commands" menu lets you adjust Document Properties, Export Options, and more.
[bookmark: _Toc229404347]Options and Commands Menu
The Options and Commands menu, represented by an icon with three lines, provides additional configuration options for your document. For example, in Google Docs, you can edit the document's name and author information for accuracy under Document Properties.
Other options include setting export preferences, under Export Options such as marking PDFs as PDF/UA compliant or selecting a default folder for exported files. This menu also allows you to view the export history for better document management.
[bookmark: _Toc229404348]Accessibility Indicators
Green Checkmark: Criterion Passed
All potential accessibility issues have been resolved.
Green Checkmark with Red Exclamation Point: Criterion Skipped with Warning
The content passes minimum technical standard, yet there are still things you can do to make the content more accessible.
Red X: Criterion Failed
Additional remediation is needed.
[image: The Grackle Docs report with a 1 marking where a red X, green checkmark, and greencheckmark with a red exclamation report appear, after the criterion being checked.]
[image: Screenshot of Grackle Docs with a criterion open, displaying a Locate+Tag button.]
Figure 6 The "Locate+Tag" button will take you to issue's location in the document.
[bookmark: _Toc229404349]Resolving Issues with Locate+Tag
The Locate+Tag feature highlights elements in your document that require attention. Issues are marked with a red Locate+Tag icon, which you can click to navigate directly to the problematic element.
Once an issue is resolved, the Locate+Tag icon turns green and includes a tag to indicate that the element has been addressed. This feature streamlines the process of identifying and fixing accessibility issues.
[bookmark: _Toc229404350]Knowledge Check 2: General Navigation
Answer the following question to self-check your knowledge (answers are at the end of the document).  
2. Select all that apply: Which features are available in the Grackle workspace to help manage and improve document accessibility?
a) The Re-Check button to update the accessibility report after changes.
b) The Export to PDF button for creating accessible PDF copies.
c) The Locate+Tag feature to identify and resolve accessibility issues.
d) The Accessibility Indicators menu for editing document properties.
e) The Auto-Update feature that automatically refreshes the accessibility report.
[bookmark: _Toc229404351]Grackle Docs
[image: A sample Google Doc with Grackle Docs open in a side panel.]
[bookmark: _Toc229404352]Ensuring Accessibility with Grackle Docs
Document Structure
Before reviewing the Accessibility Check or exporting content, you must check the content’s logical reading order using the Document Structure tab. Grackle Docs cannot check the accuracy of the reading order, that is something you will need to do manually.
You can click on each tag in the list to see where it’s located and if it’s properly tagged with the appropriate header, image, list, or paragraph designation. If something is out of order, you can either move it using the drag and drop functionality or edit it directly in the document (by adjusting the appropriate header, list, or paragraph setting).
[image: Screenshot of Grackle Docs with the Document Structure tab circled.]
Figure 7 The "Document Structure" section allows you to re-arrange and verify the reading order of content.
[bookmark: _Toc229404353]Accessibility Check
The following criteria all need to pass with either a green checkmark or a green checkmark with a red exclamation point for your content to be considered accessible and ready for export:
Document Requirements
· Document Title is required:
· Your Google Doc’s name will be used by default. This can be edited in the Document Properties setting of Google Docs. 
· Document language should be specified: 
· the default language is English. To change the language setting, if needed, go to File>Language in Google’s toolbar.
· Note: Grackle Docs does have a tool to add the language, yet the display does appear differently based on your browser settings. For a more consistent experience, use the language tool provided by Google Docs directly. 
Images
· Images should have alternate text or mark as artifact: 
· Right-click the image, select the Alt text option from the dropdown menu, and add a meaningful description. If decorative, select “mark as artifact” in Grackle, using the Locate+TAG button for each image.
· Drawings should have alternate text or mark as artifact: 
· Right-click the drawing, select the Alt text option from the dropdown menu, and add a meaningful description. If decorative, select “mark as artifact” in Grackle, using the Locate+TAG button for each image.
· Equations should be described: 
· Add a text description near the equation or in the alt text field if it's an image. 
· Images may need to be downsampled to reduce file size: 
· Compress large images before inserting or use lower-resolution versions to reduce file size.
Heading Structure
· Headings should be used:
· Use built-in heading styles (Heading 1, Heading 2, etc.) from the toolbar to structure content.
· A single “Heading 1” should be used:
· Use only one Heading 1 for the document title. Subsections should use Heading 2 or lower.
· Headings must be properly nested:
· Ensure Heading 2 follows Heading 1, Heading 3 follows Heading 2, etc. Avoid skipping levels.
Table Guidelines
· Tables must be tagged or marked as layout tables:
· Use tables only for data. Avoid using tables for layout. Grackle will tag data tables automatically when you Export to PDF.
· The use of merged cells is not recommended:
· Avoid merging cells, as it confuses screen readers. Use separate rows/columns instead.
· The use of empty cells is not recommended:
· Fill empty cells with placeholder text like “N/A” or “Blank” to aid navigation.
Landmarks
· Headers and footers should be used (Optional):
· Add headers and footers via Insert > Headers & Footers to provide consistent navigation.
· This document contains a header but no footer:
· Add a footer with page numbers or document info for completeness.
· Footnotes should have ids:
· Use Google Docs’ built-in footnote feature (Insert > Footnote) to ensure proper tagging.
· Lists should be used where appropriate:
· Use bulleted or numbered lists instead of manual formatting for better screen reader support.
[bookmark: _Toc229404354]Content Tips
· Document should not contain unsupported contents. Avoid embedded media or unsupported widgets. Stick to text, images, tables, and lists.
· High color contrast should be used: Use dark text on light backgrounds. Avoid light gray or pastel text. Check contrast with Grackle or WebAim Color Contrast Checker(opens in a new tab) to check if the contrast ratio passes WCAG guidelines.
· Fine print should be avoided: Use readable font sizes (12pt or larger). Avoid shrinking text for disclaimers.
· All-caps styling should be avoided: Use sentence case or title case. All-caps can be hard to read and misinterpreted by screen readers.
· Adjusted alignment not suggested for non-heading text: Keep body text left-aligned for readability. Centered or justified text can hinder accessibility.
· Lengthy paragraphs should be avoided: Break long paragraphs into shorter ones for easier reading and navigation.
· Links should be informative: Use descriptive link text like “Accessibility Guidelines” instead of “Click here.”
[bookmark: _Toc229404355]Knowledge Check 3: Grackle Docs
Answer the following question to self-check your knowledge (answers are at the end of the document).  
3. What is the purpose of the Document Structure tab in Grackle Docs?
a) To export the document directly to an accessible PDF format
b) To automatically correct the logical reading order of the document
c) To check the document for unsupported content types
d) To review and manually adjust the logical reading order of the document
[bookmark: _Toc229404356]Grackle Slides
[image: Screenshot of Google Slides with the Grackle Sheets report displaying in a side panel.]
[bookmark: _Toc229404357]Ensuring Accessibility with Grackle Slides
Slide Structure
Before reviewing the Accessibility Check or exporting content, you must check the slide’s logical reading order using the Slide Structure tab. Grackle Slides cannot check the accuracy of the reading order, that is something you will need to do manually.
You can click on each tag in the list to see where it’s located and if it’s properly tagged with the appropriate header, image, list, or paragraph designation.
If something is out of order, you can either move it using the drag and drop functionality in the Slides Structure section of the sidebar or edit it directly in the slide (by moving the object out of order forward or backward in relation to the other objects on the slide).
[image: Screenshot of Grackle Sheets with the Slides Structure option circled.]
Figure 8 The "Slides Strucutre" section allows you to re-arrange and verify the reading order of content within each slide.
[bookmark: _Toc229404358]Accessibility Check
The following criteria all need to pass with either a green checkmark or a green checkmark with a red exclamation point for your content to be considered accessible and ready for export.
Presentation
· Presentation title is required:
· Go to File > Rename and give your presentation a clear, descriptive title. This helps screen readers and improves document organization.
· Document language should be specified:
· Set the document language via File > Language to ensure screen readers use the correct pronunciation rules.
Slides
· A slide should have a title:
· Add a title to each slide using the title placeholder or insert a text box at the top labeled as the slide’s main heading.
· Slide title should be unique:
· Avoid repeating titles like “Introduction” or “Overview.” Make each title specific to the slide’s content.
· A slide should not be empty:
· Remove blank slides or add meaningful content (text, image, or graphic) to ensure every slide contributes to the presentation.
Tables
· Tables should be tagged and described:
· Use tables only for data, not layout. Add a caption or description near the table to explain its purpose.
· The use of merged cells is not recommended:
· Avoid merging cells, as it disrupts screen reader navigation. Use separate rows/columns instead.
· The use of empty cells is not recommended:
· Fill empty cells with placeholders like “N/A” or “—” to maintain structure and clarity.
Elements
· Images should have alternative text:
· Right-click the image, select the “Alt text”option from the dropdown menu, and add a meaningful description. If decorative, select “mark as artifact” in Grackle, using the Locate+TAG button for each image.
· Elements should have alternative text:
· Shapes, charts, and other visual elements require alt text, like images do. Right-click the shape, chart, or other visual element, select the “Alt text”option from the dropdown menu, and add a meaningful description. If decorative, select “mark as artifact” in Grackle, using the Locate+TAG button for each image.
· Text boxes should not be empty:
· Delete unused text boxes or add relevant content to avoid confusion for screen readers.
· Lists should not be broken apart:
· Use the built-in bulleted or numbered list tools instead of manually spacing or separating list items.
[bookmark: _Toc229404359]Content Tips
· Fine print should be avoided: Use readable font sizes (minimum 12pt). Avoid shrinking text for disclaimers or footnotes.
· High color contrast should be used: Ensure text color contrasts strongly with the background. Use tools like Grackle or WebAim Color Contrast Checker to check the contrast level.
· In-line style changes may lack clear meaning: Avoid excessive use of bold, italics, or color changes within paragraphs. Use headings and lists for structure.
· Empty trailing lines could be removed: Delete extra blank lines at the end of text boxes or slides to streamline navigation and reduce confusion.
[bookmark: _Toc229404360]Knowledge Check 4: Grackle Sheets
Answer the following question to self-check your knowledge (answers are at the end of the document).  
4. Which of the following practices help ensure accessibility in Grackle Slides? Select all that apply.
a) Add alternative text to images and visual elements.
b) Use merged cells in tables for better layout.
c) Set a unique title for each slide.
d) Ensure high color contrast between text and background.
e) Leave empty text boxes on slides for future edits.
[bookmark: _Toc229404361]Grackle Sheets
[image: Screenshot of Google Sheets with Grackle Sheet's report open in a side panel.]
[bookmark: _Toc229404362]Ensuring Accessibility with Grackle Sheets
The following criteria all need to pass with either a green checkmark or a green checkmark with a red exclamation point for your content to be considered accessible and ready for export.
Sheets
· Sheets document needs a proper title
· Use a clear, descriptive title at the top of the first sheet or in the document name. Avoid vague titles like “Sheet1.”
· Sheet names should be descriptive
· Rename sheets to reflect their content (e.g., “Student Grades,” “Budget Summary”). Right-click the tab and select Rename from the dropdown menu.
· The number of sheets should be reasonable:
· Limit the number of sheets to what’s necessary. Too many sheets can overwhelm users.
· Avoid making sheets too large
· Break large datasets into smaller, manageable sheets, to avoid excessive scrolling.
· Sheets should not be empty
· Remove unused sheets or add a note explaining their purpose if they must remain.
Tables
· Tables should have headers
· Use the first row for column headers. Format them with bold text and freeze the row (View > Freeze > 1 row) for easier navigation.
· Tables should not be too long
· Split long tables across multiple sheets or sections. Consider summarizing data where feasible.
· The number of tables should be reasonable
· Avoid cluttering a single sheet with multiple unrelated tables. Use separate sheets if needed.
· The use of merged cells is not recommended
· Avoid merging cells, especially in headers or data tables, as it disrupts screen reader flow.
· Avoid isolated cells
· Ensure all data is part of a structured table. Avoid placing single cells far from the main content.
[bookmark: _Toc229404363]Content Tips
· Images should have alternate text: Right-click the image, select the Alt text option from the dropdown menu, and add a meaningful description. If decorative, select “mark as artifact” in Grackle, using the Locate+TAG button for each image
· Charts should have alternate text: Charts require alt text, like images do. Right-click the shape, chart, or other visual element, select the Alt text option from the dropdown menu, and add a meaningful description. If decorative, select “mark as artifact” in Grackle, using the Locate+TAG button for each image
· High color contrast should be used: Use dark text on light backgrounds. Avoid light gray or pastel text. Grackle Sheets or WebAim Color Contrast Checker (opens in a new tab)can help check contrast.
· Fine print should be avoided: Use readable font sizes (12pt or larger). Avoid shrinking text to fit more data.
[bookmark: _Toc229404364]Knowledge Check 5: Grackle Sheets
Answer the following question to self-check your knowledge (answers are at the end of the document).  
5. Which of the following practices help ensure accessibility when using Grackle Sheets? Select all that apply.
a) Avoid empty cells.
b) Add alternate text to images and charts to describe their content.
c) Include as many sheets as possible to organize data comprehensively.
d) Merge cells in headers to make them visually appealing.
e) Use descriptive titles for sheets and avoid vague names like 'Sheet1'.
[bookmark: _Toc229404365]Conclusion
You have completed the Grackle Accessibility Guide!
Please fill out the following form to record your completion of this guide and to provide feedback for improvements. 
[bookmark: _Toc229404366]Knowledge Check Answer Key
1. A, B, and C
2. C
3. D
4. A, C, and D
5. A, B, and E
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